cannot activate lux render

Use this forum for general user support and related questions.
centauri
Posts: 7
Joined: Tue Sep 25, 2018 2:06 pm

Re: cannot activate lux render

Post by centauri » Tue Sep 25, 2018 4:04 pm

Hi,

I have got the same problem here.

Considering your suggestions:
I wouldn't know of any python installation on my system. Python itself I never installed. Blender always worked without this, it is because there is a python version coming with the Blender package I guess.

Ok what else:
Re-Installing Blender, If i just use the zip version of Blender, doesnt make sence. But I deleted the complete configuration files instead and tried again.
I have a 64bit System and using the 64bit 2.79b Blender Version, freshly downloaded.
Also I installed the C++ Redistributable.

Other than that I could make Luxcorerender run on another system today and I am really, really impressed! This is a huge improvement over Luxrender, mostly I like the much better integration into blender & user friendliness.

Thanks for your support

User avatar
B.Y.O.B.
Developer
Posts: 1585
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: cannot activate lux render

Post by B.Y.O.B. » Tue Sep 25, 2018 4:38 pm

You are getting the exact same error messages?
They are really weird, requests and urllib3 are modules that are included in the Python standard library, they are always available and should work.
Support LuxCoreRender project with salts and bounties

centauri
Posts: 7
Joined: Tue Sep 25, 2018 2:06 pm

Re: cannot activate lux render

Post by centauri » Tue Sep 25, 2018 4:50 pm

Well, now that I checked in more detail, my error description is only similar. The first error is the same, the second one is different.

Traceback (most recent call last):
File "C:\Program Files\Blender Foundation\Blender\2.79\scripts\modules\addon_utils.py", line 331, in enable
mod = __import__(module_name)
File "C:\Users\secret\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\BlendLuxCore\__init__.py", line 13, in <module>
from .bin import.pyloxcore

ImportError: DLL load failed: Das angegebene Modul wurde nicht gefunden.

so there is no problem with the modules "requests" and "urllib3", rather it seems like it tries to import a module that is not specified (module_name)

User avatar
B.Y.O.B.
Developer
Posts: 1585
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: cannot activate lux render

Post by B.Y.O.B. » Tue Sep 25, 2018 5:43 pm

centauri wrote:
Tue Sep 25, 2018 4:50 pm
Traceback (most recent call last):
File "C:\Program Files\Blender Foundation\Blender\2.79\scripts\modules\addon_utils.py", line 331, in enable
mod = __import__(module_name)
File "C:\Users\secret\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\BlendLuxCore\__init__.py", line 13, in <module>
from .bin import.pyloxcore

ImportError: DLL load failed: Das angegebene Modul wurde nicht gefunden.
Ok so pyluxcore fails to load (although I find it weird that it says "pyloxcore", with an "o" instead of "u"?).
Which version do you try to install?
If it's v2.1alpha3, you also need the intel redistributable: https://software.intel.com/sites/defaul ... .3.210.zip

Also, just to make sure, you have downloaded the correct zip package for your system from the release section, right?
https://github.com/LuxCoreRender/BlendLuxCore/releases
You can not combine the latest BlendLuxCore sources with outdated LuxCore binaries (you would have to recompile them).
Just in case you tried using the latest BlendLuxCore sources.
centauri wrote:
Tue Sep 25, 2018 4:04 pm
Other than that I could make Luxcorerender run on another system today and I am really, really impressed! This is a huge improvement over Luxrender, mostly I like the much better integration into blender & user friendliness.
Thanks for the positive feedback, glad to hear that :)
Back on topic: which system was this exactly, why did it work there an not on your other system?
Support LuxCoreRender project with salts and bounties

centauri
Posts: 7
Joined: Tue Sep 25, 2018 2:06 pm

Re: cannot activate lux render

Post by centauri » Tue Sep 25, 2018 5:51 pm

B.Y.O.B. wrote:
Tue Sep 25, 2018 5:43 pm
Ok so pyluxcore fails to load (although I find it weird that it says "pyloxcore", with an "o" instead of "u"?).
Sorry, again my bad! I just typed it out manually and it is saying "pyluxcore" of course. I dont want to cause more confusion :lol:
B.Y.O.B. wrote:
Tue Sep 25, 2018 5:43 pm
Which version do you try to install?
I took the official download which is there called "BlendLuxCore-v2.0-win64-opencl"


I searched for the module and it is present here

...\Blender Foundation\Blender\2.79\scripts\addons\BlendLuxCore\bin\pyluxcore.pyd

please notice the ending *.pyd ... ? I changed it to *.py just to test it, but nope...
B.Y.O.B. wrote:
Tue Sep 25, 2018 5:43 pm
which system was this exactly, why did it work there an not on your other system?
Why did it work there? If I knew that I would fix it here :D ...the working system is a laptop with Windows 10, the non working is a desktop PC with Windows 10 as well
Last edited by centauri on Tue Sep 25, 2018 6:01 pm, edited 1 time in total.

User avatar
B.Y.O.B.
Developer
Posts: 1585
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: cannot activate lux render

Post by B.Y.O.B. » Tue Sep 25, 2018 6:01 pm

Can you try the latest alpha from https://github.com/LuxCoreRender/BlendLuxCore/releases?
(Don't forget the intel thing: https://software.intel.com/sites/defaul ... .3.210.zip)
And make sure you have installed the Visual C++ Redist. stuff: https://www.microsoft.com/en-US/downloa ... x?id=40784

Do you have the old LuxBlend installed?
It should not be active the same time as BlendLuxCore.
If it is active, deactivate it in the user preferences, then save user prefs and restart Blender, then activate BlendLuxCore.
please notice the ending *.pyd ... ?
That is correct, it's some kind of Python DLL file, not a normal .py file.
Support LuxCoreRender project with salts and bounties

centauri
Posts: 7
Joined: Tue Sep 25, 2018 2:06 pm

Re: cannot activate lux render

Post by centauri » Tue Sep 25, 2018 6:27 pm

B.Y.O.B. wrote:
Tue Sep 25, 2018 6:01 pm
Can you try the latest alpha from https://github.com/LuxCoreRender/BlendLuxCore/releases?
(Don't forget the intel thing: https://software.intel.com/sites/defaul ... .3.210.zip)
And make sure you have installed the Visual C++ Redist. stuff: https://www.microsoft.com/en-US/downloa ... x?id=40784

Do you have the old LuxBlend installed?
It should not be active the same time as BlendLuxCore.
If it is active, deactivate it in the user preferences, then save user prefs and restart Blender, then activate BlendLuxCore.
both installed. same error with 2.1 alpha.

Old Lux removed too. As I have writte earlier, I also tried removing all stuff from the local app path. That should do the same.
Last edited by centauri on Tue Sep 25, 2018 6:33 pm, edited 2 times in total.

centauri
Posts: 7
Joined: Tue Sep 25, 2018 2:06 pm

Re: cannot activate lux render

Post by centauri » Tue Sep 25, 2018 8:00 pm

Ok so I googled again. This guy seems to have had the same problem and found a workaround by putting the OpenCL path in his System Variables list into quotation marks (because the path contained a spaces).

https://github.com/LuxCoreRender/BlendL ... issues/138

So I checked my System Variables too but I had no such OpenCL path. Why could this be? Is there another installation required? OpenCL with Luxrender worked well before.

Ok at least that brought me to the idea to try the non-OpenCL version and voila, that one can be activated and renders smoothly!

but of course in the future i would like to try the OpenCL version!

kintuX
Posts: 207
Joined: Wed Jan 10, 2018 2:37 am

Re: cannot activate lux render

Post by kintuX » Tue Sep 25, 2018 8:35 pm

Had similar OCL issues here with few NVidia drivers. IIRC, between versions 377 and 391 were broken.

User avatar
B.Y.O.B.
Developer
Posts: 1585
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: cannot activate lux render

Post by B.Y.O.B. » Tue Sep 25, 2018 9:20 pm

Try LuxMark to see if your OpenCL installation is working correctly.
Maybe try to reinstall/update your graphics driver.
Support LuxCoreRender project with salts and bounties

Post Reply