OLD LUXCORE - Shadowcatcher not fully transparent

Use this forum for general user support and related questions.
Asticles
Donor
Posts: 151
Joined: Thu Jan 11, 2018 8:52 am

OLD LUXCORE - Shadowcatcher not fully transparent

Post by Asticles » Thu Jan 11, 2018 10:24 am

Hi all,

This maybe is not a bug, but since the begining, shadowcatcher material is not transparent as it should.
Look at the images, on the left: Lightwave's shadow catcher on a plane with a gradient background.
On the right, luxcore one.
Screenshot.jpg
Best regards.
Last edited by Asticles on Fri Jan 12, 2018 11:41 am, edited 1 time in total.
Salvador Ureña

User avatar
B.Y.O.B.
Developer
Posts: 3348
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Shadowcatcher not fully transparent

Post by B.Y.O.B. » Thu Jan 11, 2018 11:18 am

The lower half of the environment light has to be black.
Also, you should use a sun light only (no sky) if you want a pitch black unrealistic shadow like on the left.

Asticles
Donor
Posts: 151
Joined: Thu Jan 11, 2018 8:52 am

Re: Shadowcatcher not fully transparent

Post by Asticles » Thu Jan 11, 2018 12:18 pm

Thanks for the response,
On the left there is no gi, this is why the shadow is pitch black.
So, it only works with Hemi with upper hemisphere?
Salvador Ureña

User avatar
Dade
Developer
Posts: 3909
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Shadowcatcher not fully transparent

Post by Dade » Thu Jan 11, 2018 1:35 pm

BTW, there is a dedicated flag in LuxCore for rendering the lower half hemisphere in black :idea:
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3348
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Shadowcatcher not fully transparent

Post by B.Y.O.B. » Thu Jan 11, 2018 2:44 pm

In theory you have two options:
  • use sky light and set ground color and ground albedo to black
  • use HDRI and enable "sampleupperhemisphereonly"
However, the second option does not seem to work when I test it here (the plane is still lit from below).
Attachments
sky light with ground color and ground albedo black
sky light with ground color and ground albedo black
hdri with sampleupperhemisphereonly
hdri with sampleupperhemisphereonly

User avatar
Dade
Developer
Posts: 3909
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Shadowcatcher not fully transparent

Post by Dade » Thu Jan 11, 2018 3:58 pm

B.Y.O.B. wrote:
Thu Jan 11, 2018 2:44 pm
However, the second option does not seem to work when I test it here (the plane is still lit from below).
It is lit by indirect light, "sampleupperhemisphereonly" disable direct light sampling of lower hemisphere but doesn't change the correctness of the rendering. It was introduced for LDR images: http://www.luxrender.net/forum/viewtopi ... 10#p120871

But back in topic, I have lost a bit the track of the problem, what is exactly the problem ?

@Asticles, is the shadow too "bright" ? Have you tried to set the material of plane to something nearly black ? Or have you tried to limit the max. path depth to render only direct light in order to compare "orange" to "orange" with Lightwave ?

The plane should no be visible at all outside of the shadow, can you post a test scene ?
Support LuxCoreRender project with salts and bounties

Asticles
Donor
Posts: 151
Joined: Thu Jan 11, 2018 8:52 am

Re: Shadowcatcher not fully transparent

Post by Asticles » Thu Jan 11, 2018 6:03 pm

Sorry Dade,

To me the topic is to have a feature without workarounds and conditionals. I think shadowcatcher should be bulletproof and work always.
I've post the Lightwave example, but it also works with Gi enabled.

I've seen that setting the shadow material to diffuse you can control the color, but if you set the color to pure black, the shadow catcher fails.

The test scene was only a plane with the man and the hemi lamp.
Salvador Ureña

Asticles
Donor
Posts: 151
Joined: Thu Jan 11, 2018 8:52 am

Re: Shadowcatcher not fully transparent

Post by Asticles » Thu Jan 11, 2018 6:12 pm

Maybe I'm wrong, but I prefer less features but rock solid than more features but working only on specific conditions.
IMHO.
Salvador Ureña

User avatar
Sharlybg
Donor
Posts: 1816
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Shadowcatcher not fully transparent

Post by Sharlybg » Thu Jan 11, 2018 7:09 pm

Maybe I'm wrong, but I prefer less features but rock solid than more features but working only on specific conditions.
IMHO.
This is why we are doing testing. Trying to improve everything but step by step.this is why it is called an alpha stage.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Dade
Developer
Posts: 3909
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Shadowcatcher not fully transparent

Post by Dade » Thu Jan 11, 2018 7:53 pm

Asticles wrote:
Thu Jan 11, 2018 6:03 pm
To me the topic is to have a feature without workarounds and conditionals. I think shadowcatcher should be bulletproof and work always.
I've post the Lightwave example, but it also works with Gi enabled.

I've seen that setting the shadow material to diffuse you can control the color, but if you set the color to pure black, the shadow catcher fails.

The test scene was only a plane with the man and the hemi lamp.
In my tests with a plane and an hemi lamp is working fine. I guess you have some setting different from mine. I can try to figure out what is going wrong alone but having an example of the problem could probably save me a lot of time.
Support LuxCoreRender project with salts and bounties

Post Reply