Page 2 of 2

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Posted: Thu Nov 12, 2020 2:04 pm
by Marko Posavec
B.Y.O.B. wrote:
Thu Nov 12, 2020 1:48 pm
kintuX wrote:
Thu Nov 12, 2020 1:24 pm
Marko Posavec wrote:
Thu Nov 12, 2020 7:42 am
I tried enabling the auto smooth option under the Object Properties > Normals section, no change.
Note: For time being, it's not implemented for the latest Blender versions - only works with Blender 2.83 LTS :!:
Bypass - Use Edge split modifier.
auto smooth alone should work, only custom normals aren't supported. Or am I wrong?
I didn't get any errors in 2.9 for auto smooth so it probably works? In contrast when I imported a Maya mesh it complained about custom Normals. At first I thought that was the problem. I created this test scene only with blender so custom Normals don't seem to be a problem. Also moments ago I tried with auto smoothing in 283 and it doesn't fix the problem with circular shading artifact on top of the sphere. Still some other problems possible with normals?

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Posted: Sat Nov 21, 2020 8:00 pm
by kintuX
B.Y.O.B. wrote:
Thu Nov 12, 2020 1:48 pm
kintuX wrote:
Thu Nov 12, 2020 1:24 pm
Marko Posavec wrote:
Thu Nov 12, 2020 7:42 am
I tried enabling the auto smooth option under the Object Properties > Normals section, no change.
Note: For time being, it's not implemented for the latest Blender versions - only works with Blender 2.83 LTS :!:
Bypass - Use Edge split modifier.
auto smooth alone should work, only custom normals aren't supported. Or am I wrong?
Right you are :D