Light cut off problem when using Bidir and Metropolis. How to fix?

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
Marko Posavec
Posts: 7
Joined: Tue Nov 10, 2020 12:19 pm

Light cut off problem when using Bidir and Metropolis. How to fix?

Post by Marko Posavec » Tue Nov 10, 2020 1:02 pm

Hello,
I am new to Blender and LuxCore.
When trying to render a scene with LuxCore using the Bidir Engine and Metropolis Sampling... A Light cutoff artifact appears on a Diffuse Background Surface visible in a specular reflection.
I made a comparison render with the Path Tracing Engine and it shows no problems.

Light Paths > Clamping -- is not enabled in the Render Properties.

There are two pictures one with Path Tracing and one with Bidir + Metropolis. To see the difference more clearly it is best to Download the images and flip back and forth between them. Also There is a matching Blender scene attachment.

To me It looks like some kind of a light cutoff threshold problem.
What is it actually? How can this be fixed?

Thank you,
Marko Posavec
Attachments
Path Tracing - No Problem
Path Tracing - No Problem
Bidir Metropolis - Circular Light Cutoff at the top
Bidir Metropolis - Circular Light Cutoff at the top
CutoffProblem_283.blend
Example Blender Scene File.
(1.09 MiB) Downloaded 13 times

User avatar
Dade
Developer
Posts: 4817
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by Dade » Wed Nov 11, 2020 9:51 am

Marko Posavec wrote:
Tue Nov 10, 2020 1:02 pm
What is it actually? How can this be fixed?
Your scene has a max. path depth of 5+5 (eye path depth + light path depth) with BiDir: the longest path traced will include 10 bounces. While your Path tracing max. depth is 5 (path tracing only trace eye paths).

BiDir traces longer paths and transport more indirect light so the result is brighter.

BTW, I don't know if you are aware but you are using 228 light sources (the 228 triangles of the bright sphere): it is very very inefficient and a bad idea in general.
Support LuxCoreRender project with salts and bounties

Marko Posavec
Posts: 7
Joined: Tue Nov 10, 2020 12:19 pm

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by Marko Posavec » Wed Nov 11, 2020 12:27 pm

I knew that using mesh-lights is not super efficient but, being equivalent to using the same number of lights as triangles... that I did not expect. :shock:
I wanted a sphere light for this scene so that it sends light in all directions. I did not check if a point-light could do that.

Also I was not aware of how tracing depths work in Lux, so that means I should do the following to make the renders match between (Bidir + Metropolis) and (Path Tracing)?
Path Tracing:
Total Path Depth - 10
Diffuse - 10
Glossy - 10
Specular - 10
Bidir + Metropolis:
Eye Depth: 5
Light Depth: 5
Is this correct? I tried this and still the Bidir + Metropolis render is brighter. (possibly because of better caustic sampling?)

:arrow: I'm not sure if you are understanding what my problem is.
Do you see a circular shading artifact on top of the sphere when using Bidir + Metropolis render?
I tried everything you suggested and still the artifact is there, even after using a point light instead of the meshlight.
Radius and power are the same, still the artifact persists.
Is this a problem with the render engine or am I doing something wrong?

User avatar
Dade
Developer
Posts: 4817
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by Dade » Wed Nov 11, 2020 3:43 pm

Marko Posavec wrote:
Wed Nov 11, 2020 12:27 pm
I wanted a sphere light for this scene so that it sends light in all directions. I did not check if a point-light could do that.
Yes, point lights can have radius (aka sphere lights).
Marko Posavec wrote:
Wed Nov 11, 2020 12:27 pm
Also I was not aware of how tracing depths work in Lux, so that means I should do the following to make the renders match between (Bidir + Metropolis) and (Path Tracing)?
Path Tracing:
Total Path Depth - 10
Diffuse - 10
Glossy - 10
Specular - 10
Bidir + Metropolis:
Eye Depth: 5
Light Depth: 5
Is this correct?
Not exactly because the way BiDir works (i.e. the way eye and light paths are connected). You may use 32+32 for BiDir and 64 for path in order to "leverage" the unbias-innes of the rende engines and get similar results: at some point the length of the paths will not matter because they will transport very little light energy.
Marko Posavec wrote:
Wed Nov 11, 2020 12:27 pm
:arrow: I'm not sure if you are understanding what my problem is.
No, I didn't, I see now the top circle artifact reflected on the sphere. I will check. It may be some kind of precision/limited color resolution problem: your "room" is a sphere too and normal interpolation may be a problem (for instance, does it happen with a cube too ?).
Support LuxCoreRender project with salts and bounties

Marko Posavec
Posts: 7
Joined: Tue Nov 10, 2020 12:19 pm

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by Marko Posavec » Wed Nov 11, 2020 3:57 pm

No, I didn't, I see now the top circle artifact reflected on the sphere. I will check. It may be some kind of precision/limited color resolution problem: your "room" is a sphere too and normal interpolation may be a problem (for instance, does it happen with a cube too ?).
I did not test with a cube precisely because I suspect that the "threshold problem" could "get stuck in the corner" and be very difficult to tease out if you know what I mean. This was the simplest scene I could come up with to demonstrate the problem as clearly as possible. My original scene used a cylinder instead. A similar problem happened with the cylinder as well.

Marko Posavec
Posts: 7
Joined: Tue Nov 10, 2020 12:19 pm

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by Marko Posavec » Wed Nov 11, 2020 5:06 pm

When the scene is contained in a cube instead of a sphere the artifact is not visible. Tried with several cube room sizes and nothing. But I can't be sure if it's not there 100%. To me it looks like it might be caused by the indirect light reflected from the metal ball somehow.
Not exactly because the way BiDir works (i.e. the way eye and light paths are connected). You may use 32+32 for BiDir and 64 for path in order to "leverage" the unbias-innes of the rende engines and get similar results: at some point the length of the paths will not matter because they will transport very little light energy.
Now I understand it makes perfect sense if render engines render with many bounces and for a long time the results will converge because both are unbiased.

Thank you for your replies Dade :)

Marko Posavec
Posts: 7
Joined: Tue Nov 10, 2020 12:19 pm

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by Marko Posavec » Thu Nov 12, 2020 7:42 am

No, I didn't, I see now the top circle artifact reflected on the sphere. I will check. It may be some kind of precision/limited color resolution problem: your "room" is a sphere too and normal interpolation may be a problem (for instance, does it happen with a cube too ?).
I tried enabling the auto smooth option under the Object Properties > Normals section, no change.
Rotated both the spheres at an angle. No effect on the artifact.
Scaled the scene container sphere 2x, light level drops at the top but the artifact is unchanged. I guess this excludes the possibility that it is a distance threshold.

From the above tests I can conclude that you are right It could be the Normals but what can I do about it?

kintuX
Posts: 594
Joined: Wed Jan 10, 2018 2:37 am

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by kintuX » Thu Nov 12, 2020 1:24 pm

Marko Posavec wrote:
Thu Nov 12, 2020 7:42 am
I tried enabling the auto smooth option under the Object Properties > Normals section, no change.
Note: For time being, it's not implemented for the latest Blender versions - only works with Blender 2.83 LTS :!:
Bypass - Use Edge split modifier.

User avatar
B.Y.O.B.
Developer
Posts: 3871
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by B.Y.O.B. » Thu Nov 12, 2020 1:48 pm

kintuX wrote:
Thu Nov 12, 2020 1:24 pm
Marko Posavec wrote:
Thu Nov 12, 2020 7:42 am
I tried enabling the auto smooth option under the Object Properties > Normals section, no change.
Note: For time being, it's not implemented for the latest Blender versions - only works with Blender 2.83 LTS :!:
Bypass - Use Edge split modifier.
auto smooth alone should work, only custom normals aren't supported. Or am I wrong?

Marko Posavec
Posts: 7
Joined: Tue Nov 10, 2020 12:19 pm

Re: Light cut off problem when using Bidir and Metropolis. How to fix?

Post by Marko Posavec » Thu Nov 12, 2020 2:00 pm

kintuX wrote:
Thu Nov 12, 2020 1:24 pm
Note: For time being, it's not implemented for the latest Blender versions - only works with Blender 2.83 LTS :!:
Bypass - Use Edge split modifier.
I tried the 283 version of blender to get the smoothing to work.
But unfortunately this doesn't affect the end result. The artifact visible on the top of the sphere still appears.

Post Reply