Very long wait for caches enabled

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
nigma46
Posts: 28
Joined: Fri Nov 06, 2020 5:40 am

Very long wait for caches enabled

Post by nigma46 » Fri Nov 06, 2020 5:52 am

Hi,

I am a new blendluxcore user and a new Blender user.

I am finding luxcore to be superior to regular cycles when rendering my scene, which is the Roman Pantheon. A challenging scene to light due to the singular circlular opening in the roof, the oculus. I prefer to light with a single HDRI, to get the most realistic lighting.

However, the issue I am having is that when attempting to use caches, photogi indirect and/or environment cache, i have to wait 20-30mins before the render starts, if it starts at all. Is this because of my complexe scene (>100 MTris)? I'd prefer to use the caches, since when it works I see the speed improvement.

Running Blender v2.90, Win10 64bit, nVidia drivers: 452.06
i7 3770k /w 24GB ram, 980 GTX
Attachments
Image0028_pregamma_1_durand_spatial_90_range_7.5_base_4.8_postsaturation_1_postgamma_1.jpg

nigma46
Posts: 28
Joined: Fri Nov 06, 2020 5:40 am

Re: Very long wait for caches enabled

Post by nigma46 » Fri Nov 06, 2020 9:36 am

Update:

I had been using luxcore 2.4 with Blender 2.9. But I just tried the daily release of luxcore 2.5 and with environment light cache only enabled it completed in 2.5 minutes, instead of the 10 minutes with luxcore 2.4, excellent! If I enable photongi it doesn't complete even after 50 mins. =/

User avatar
Sharlybg
Donor
Posts: 2627
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Very long wait for caches enabled

Post by Sharlybg » Fri Nov 06, 2020 10:43 am

nigma46 wrote:
Fri Nov 06, 2020 9:36 am
Update:

I had been using luxcore 2.4 with Blender 2.9. But I just tried the daily release of luxcore 2.5 and with environment light cache only enabled it completed in 2.5 minutes, instead of the 10 minutes with luxcore 2.4, excellent! If I enable photongi it doesn't complete even after 50 mins. =/
can you show the concerned Cache setting you have ?
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

nigma46
Posts: 28
Joined: Fri Nov 06, 2020 5:40 am

Re: Very long wait for caches enabled

Post by nigma46 » Fri Nov 06, 2020 10:59 am

Sharlybg: Sure, see attached. I've tried photongi with default settings. It is currently turned off in the screenshot, but i was using default settings.
Attachments
Capture.PNG

User avatar
Sharlybg
Donor
Posts: 2627
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Very long wait for caches enabled

Post by Sharlybg » Fri Nov 06, 2020 11:26 am

Reduce your photon count to 2 million instead of current 20 millions.
reduce your brute force radius scale to 1 instead of 8 and try render again.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
B.Y.O.B.
Developer
Posts: 4032
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Very long wait for caches enabled

Post by B.Y.O.B. » Fri Nov 06, 2020 11:30 am

Brute force radius scale has no influence on the cache building time, it only influences rendering performance after the cache is built.

@OP:
Can you provide a stripped-down simplified testscene that still shows the problem? Try removing textures, replacing high-poly objects with simplified meshes, etc.
Please also mention what kind of hardware you are rendering on.
Another good thing to have would be a log output from the console.

nigma46
Posts: 28
Joined: Fri Nov 06, 2020 5:40 am

Re: Very long wait for caches enabled

Post by nigma46 » Fri Nov 06, 2020 11:42 am

B.Y.O.B. wrote:
Fri Nov 06, 2020 11:30 am
Brute force radius scale has no influence on the cache building time, it only influences rendering performance after the cache is built.

@OP:
Can you provide a stripped-down simplified testscene that still shows the problem? Try removing textures, replacing high-poly objects with simplified meshes, etc.
Please also mention what kind of hardware you are rendering on.
Another good thing to have would be a log output from the console.
thanks for youre reply. I am rendering with GPU only, a 980gtx card.

I dont have any textures except for blueprints on large planes, these are hidden from rendering in cycles, it seems this setting also applied for luxcore. I could try remove these planes from the scene as a test.

I dont have an easy way to reduce the poly count in my scene other than use the simplify option that exists in cycles, though I have been working if luxcore can read this setting, can it? I think it might as I think I remember setting it to 0 subdivision surfaces for render and thought i noticed reduced polys in luxcore.

nigma46
Posts: 28
Joined: Fri Nov 06, 2020 5:40 am

Re: Very long wait for caches enabled

Post by nigma46 » Fri Nov 06, 2020 11:43 am

Sharlybg wrote:
Fri Nov 06, 2020 11:26 am
Reduce your photon count to 2 million instead of current 20 millions.
reduce your brute force radius scale to 1 instead of 8 and try render again.
I think I did try reduce photon count, but got light leaks and pre-render calc time didn't seem to decrease much.

User avatar
Sharlybg
Donor
Posts: 2627
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Very long wait for caches enabled

Post by Sharlybg » Fri Nov 06, 2020 11:58 am

Brute force radius scale has no influence on the cache building time, it only influences rendering performance after the cache is built.
yes i know that. i want affect both build time and rendering perf.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

nigma46
Posts: 28
Joined: Fri Nov 06, 2020 5:40 am

Re: Very long wait for caches enabled

Post by nigma46 » Fri Nov 06, 2020 9:29 pm

I tried to exclude the blueprint "emptys" from luxcore render and set PhotonGI photon number to 1 million. Still did not finish pre-calcs for 15 mins, then I cancelled.

Post Reply