Luxcore Optix crash investigation

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
User avatar
Sharlybg
Donor
Posts: 2484
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Luxcore Optix crash investigation

Post by Sharlybg » Sat Sep 26, 2020 3:15 pm

Just trying to track the 2.5 alpha repetitive crash. And it look like Optix can be related to that at some degree.

first scenario

I just found that being in Viewport GPU preview rendering (CUDA) Disable or enable optix during the render prview and then switch back
to solid view crash blender even with the cube instantly and reliablelly ;) .

Lastest Blendluxcore with Nvidia driver 452.06.

Second Crash scenario :

Switching from CPU to GPU while rendering in viewport (even without viewport denoiser enable) and back to solid view will instantly close blender : reproductible even with a CUBE.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Dade
Developer
Posts: 4817
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Luxcore Optix crash investigation

Post by Dade » Sat Sep 26, 2020 5:20 pm

Has the view port resize problem and any eventually correlated problems been fixed ? viewtopic.php?f=4&t=2309&p=25206#p25204
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3872
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Luxcore Optix crash investigation

Post by B.Y.O.B. » Sun Sep 27, 2020 11:56 am

Dade wrote:
Sat Sep 26, 2020 5:20 pm
Has the view port resize problem and any eventually correlated problems been fixed ? viewtopic.php?f=4&t=2309&p=25206#p25204
I have not yet started looking into it.

User avatar
Sharlybg
Donor
Posts: 2484
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Luxcore Optix crash investigation

Post by Sharlybg » Fri Oct 02, 2020 9:12 am

B.Y.O.B. wrote:
Sun Sep 27, 2020 11:56 am
Dade wrote:
Sat Sep 26, 2020 5:20 pm
Has the view port resize problem and any eventually correlated problems been fixed ? viewtopic.php?f=4&t=2309&p=25206#p25204
I have not yet started looking into it.
Sorry to ask about it again :mrgreen: do the last build have any improvement arround this issue.It make optix denoiser very hard to work with because switching between viewport mode and device will crash again and again. :|
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

Casper
Posts: 13
Joined: Sun Apr 19, 2020 7:59 am

Re: Luxcore Optix crash investigation

Post by Casper » Sun Oct 11, 2020 6:31 pm

Windows 10 / blender 2.83.6 / BlendLuxcore (build this day) / driver Nvidia 456.38

Hi,

I see the same crash situations (ex: switch between solid and render) with the default cube.
Is there a solution to solve these problems, please ?

Thanks so much.

User avatar
Sharlybg
Donor
Posts: 2484
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Luxcore Optix crash investigation

Post by Sharlybg » Thu Oct 29, 2020 9:34 pm

B.Y.O.B. wrote:
Sun Sep 27, 2020 11:56 am
Dade wrote:
Sat Sep 26, 2020 5:20 pm
Has the view port resize problem and any eventually correlated problems been fixed ? viewtopic.php?f=4&t=2309&p=25206#p25204
I have not yet started looking into it.
Sorry for talking about that but this issue is making 2.5 barelly usable. If we can't test 2.5 lot of bug could be hided.
It is the first RTX CUDA version and still we can't try it.
It crash repeatidly when switch and even if optix isn't use in addon pref.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
B.Y.O.B.
Developer
Posts: 3872
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Luxcore Optix crash investigation

Post by B.Y.O.B. » Fri Oct 30, 2020 10:30 am

Sharlybg wrote:
Thu Oct 29, 2020 9:34 pm
It crash repeatidly when switch and even if optix isn't use in addon pref.
Interesting, on my end, it doesn't crash at all when I disable OptiX viewport denoising.

User avatar
Sharlybg
Donor
Posts: 2484
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Luxcore Optix crash investigation

Post by Sharlybg » Fri Oct 30, 2020 11:21 am

Interesting, on my end, it doesn't crash at all when I disable OptiX viewport denoising.
It will crash if you switch between GPU and CPU viewport render device during rendering and add to all that switch between solid view and rendered view.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Sharlybg
Donor
Posts: 2484
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Luxcore Optix crash investigation

Post by Sharlybg » Sun Nov 01, 2020 2:50 pm

Sharlybg wrote:
Fri Oct 30, 2020 11:21 am
Interesting, on my end, it doesn't crash at all when I disable OptiX viewport denoising.
It will crash if you switch between GPU and CPU viewport render device during rendering and add to all that switch between solid view and rendered view.
BYOB are you able to reproduce the issue with my process ? i mean switch between GPU and CPU viewport rendering as well as Rendered and solid view.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
B.Y.O.B.
Developer
Posts: 3872
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Luxcore Optix crash investigation

Post by B.Y.O.B. » Sun Nov 01, 2020 3:47 pm

Switching between GPU and CPU will require the renderconfig to be re-created, which is effectively the same as what's happening when the viewport is resized, so I guess it has the same underlying problem as this: https://github.com/LuxCoreRender/BlendL ... issues/577
Which still needs to be investigated in detail.

Post Reply