luxCore opencl error API in linux

Use this forum for general user support and related questions.
Post Reply
rikrdtir
Posts: 1
Joined: Mon Sep 14, 2020 8:48 pm

luxCore opencl error API in linux

Post by rikrdtir » Mon Sep 14, 2020 8:56 pm

How about folks, install blender with luxcore in several linux distributions, and this error always appears, also I tried with the "nonfree" drivers in distributions like arch linux, but it works for a while then the error appears.


OpenCL driver API error (code: -30, file:/home/vsts/work/1/s/LinuxCompile/LuxCore/src/luxrays/utils/ocl.cpp, line: 178): CL_INVALID_VALUE

User avatar
Dade
Developer
Posts: 4685
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: luxCore opencl error API in linux

Post by Dade » Mon Sep 14, 2020 9:34 pm

AMD or NVIDIA GPU ? Version of LuxCore used ?

First of all check if you have a working OpenCL installation by running LuxMark (i.e. if it doesn't work, there is a problem with OpenCL drivers).
Support LuxCoreRender project with salts and bounties

Post Reply