Dark poly spot

Use this forum for general user support and related questions.
Post Reply
User avatar
Sharlybg
Donor
Posts: 2288
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Dark poly spot

Post by Sharlybg » Fri Sep 11, 2020 2:45 pm

I struggling with a dark poly spot in my model in both blendluxcore 2.4 / 2.5 on CPU / GPU not in Cycles:
darkspot.jpg
Dade PM you with the file.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Dade
Developer
Posts: 4685
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Dark poly spot

Post by Dade » Sun Sep 13, 2020 2:25 pm

Exporting the scene to file system and rendering with LuxCoreUI works fine. The problem is visible only inside Blender.

Try to isolate the polygon with the problem and erase everything else.
Support LuxCoreRender project with salts and bounties

User avatar
Sharlybg
Donor
Posts: 2288
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Dark poly spot

Post by Sharlybg » Wed Sep 16, 2020 9:42 am

Dade wrote:
Sun Sep 13, 2020 2:25 pm
Exporting the scene to file system and rendering with LuxCoreUI works fine. The problem is visible only inside Blender.

Try to isolate the polygon with the problem and erase everything else.
Another user is runing in the same issue : viewtopic.php?f=10&t=2584&p=25383#p25383

here is the mesh with isolated wrong surfaces :
Darkspot bug.blend
(790.35 KiB) Downloaded 3 times
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Dade
Developer
Posts: 4685
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Dark poly spot

Post by Dade » Wed Sep 16, 2020 10:55 am

Sharlybg wrote:
Wed Sep 16, 2020 9:42 am
Dade wrote:
Sun Sep 13, 2020 2:25 pm
Exporting the scene to file system and rendering with LuxCoreUI works fine. The problem is visible only inside Blender.

Try to isolate the polygon with the problem and erase everything else.
Another user is runing in the same issue : viewtopic.php?f=10&t=2584&p=25383#p25383

here is the mesh with isolated wrong surfaces :
Darkspot bug.blend
The triangles have NaN UV coordinates:

Code: Select all

ply
format ascii 1.0
comment Created by Blender 2.83.5 - www.blender.org, source file: 'Darkspot bug.blend'
element vertex 96
property float x
property float y
property float z
property float nx
property float ny
property float nz
property float s
property float t
element face 24
property list uchar uint vertex_indices
end_header
-0.291856 -0.093864 0.682044 -0.032319 -0.999451 0.000000 nan nan
-0.300529 -0.093583 0.498582 -0.032319 -0.999451 0.000000 nan nan
-0.264689 -0.094742 0.507916 -0.032319 -0.999451 0.000000 nan nan
-0.263646 -0.094776 0.759046 -0.032319 -0.999451 0.000000 nan nan
-0.300529 -0.093583 0.498582 -0.032319 -0.999451 0.000000 nan nan
-0.301779 -0.093543 0.299369 -0.032319 -0.999451 0.000000 nan nan
-0.264892 -0.094736 0.299369 -0.032319 -0.999451 0.000000 nan nan
-0.264689 -0.094742 0.507916 -0.032319 -0.999451 0.000000 nan nan
[...]
This is a .ply file directly exported from Blender without the use of any LuxCore related code. It is a Blender bug as far as I can see.

You can report the problem to Blender developers by providing this file a telling them to export in .ply format and check the UV coordinates (aka ST coordinates).
However they may be not able to track the problem from there because the NaN may be the result of the process used to build the mesh (so they may be unable to track what tool is broken and has generated the NaN).
Support LuxCoreRender project with salts and bounties

User avatar
Sharlybg
Donor
Posts: 2288
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Dark poly spot

Post by Sharlybg » Wed Sep 16, 2020 11:54 am

You can report the problem to Blender developers by providing this file a telling them to export in .ply format and check the UV coordinates (aka ST coordinates).
Thanks Dade it is done here : https://developer.blender.org/T80835
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Leandro Oliveira
Posts: 34
Joined: Thu Aug 27, 2020 6:05 pm

Re: Dark poly spot

Post by Leandro Oliveira » Wed Sep 16, 2020 12:26 pm

What does NaN mean?

User avatar
Sharlybg
Donor
Posts: 2288
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Dark poly spot

Post by Sharlybg » Wed Sep 16, 2020 12:52 pm

Answer from brecht :
However they may be not able to track the problem from there because the NaN may be the result of the process used to build the mesh (so they may be unable to track what tool is broken and has generated the NaN).

This is correct. This bug report requires steps to get a mesh into a state where UVs are NaN, otherwise we can't investigate it.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Sharlybg
Donor
Posts: 2288
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Dark poly spot

Post by Sharlybg » Wed Sep 16, 2020 1:07 pm

Ok so a simple unwrapp can fix the issue :D And it work !
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
B.Y.O.B.
Developer
Posts: 3768
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Dark poly spot

Post by B.Y.O.B. » Wed Sep 16, 2020 1:12 pm

Leandro Oliveira wrote:
Wed Sep 16, 2020 12:26 pm
What does NaN mean?
Not a Number.
It is usually the result of an invalid computation, e.g. division by zero.

User avatar
Leandro Oliveira
Posts: 34
Joined: Thu Aug 27, 2020 6:05 pm

Re: Dark poly spot

Post by Leandro Oliveira » Wed Sep 16, 2020 1:23 pm

Thanks, B.Y.O.B.! ;)

Post Reply