MacOS High Sierra BVHKernel CUDA program compilation error

Use this forum for general user support and related questions.
Post Reply
Dieneel
Posts: 2
Joined: Wed Sep 09, 2020 3:31 am

MacOS High Sierra BVHKernel CUDA program compilation error

Post by Dieneel » Wed Sep 09, 2020 3:55 am

Hey Guys, i run into CUDA probolems when using Luxocre on High Sierra:
If anyone would help, that would be really appreciated.

So here is basic info

Basic info:
OS: MacOS High Sierra
GPU: GTX1080
CUDA Driver Version: 418.243(on CUDA 10.1) or 440.89(on CUDA 10.2)
GPU Driver Version: 387.10.10.10.40.138
CUDA Tool Kit version: 10.1 & 10.2 both installed
Blender Version: 2.8.3.4
Blender Luxcore build: 2.4 or. 2.5 latest

First, I installed Cuda Tool Kit 10.1, I tried both Luxcore 2.4 and 2.5 on blender 2.8.3, it says BVHKernel CUDA program compilation error.
Then, I update to Cuda 10.2, I tried both Luxcore 2.4 and 2.5 on blender 2.8.3, it says BVHKernel CUDA program compilation error.

Here is the report when running blender through the terminal:

[LuxRays][16.913] [Device GeForce GTX 1080 CUDAIntersect] BVH mesh vertices buffer size: 576bytes
[LuxRays][16.914] [Device GeForce GTX 1080 CUDAIntersect] BVH nodes buffer size: 1248bytes
[LuxRays][16.914] [BVHKernel] Compiler options: -D LUXRAYS_OPENCL_KERNEL -D PARAM_RAY_EPSILON_MIN=1e-05f -D PARAM_RAY_EPSILON_MAX=0.1f -D LUXRAYS_CUDA_DEVICE -D LUXRAYS_OS_APPLE --use_fast_math
[LuxRays][16.914] [BVHKernel] Compiling kernels
[LuxRays][16.915] [BVHKernel] CUDA program compilation error:
nvrtc: error: failed to open libnvrtc-builtins.dylib.
Make sure that libnvrtc-builtins.dylib is installed correctly.
ERROR: BVHKernel CUDA program compilation error
Traceback (most recent call last):
File "/Users/quentin/Library/Application Support/Blender/2.83/scripts/addons/BlendLuxCore/engine/viewport.py", line 54, in view_update
engine.session = engine.exporter.create_session(depsgraph, context, engine=engine)
File "/Users/quentin/Library/Application Support/Blender/2.83/scripts/addons/BlendLuxCore/export/__init__.py", line 215, in create_session
pyluxcore.KernelCacheFill(config_props_copy)
RuntimeError: BVHKernel CUDA program compilation error

User avatar
Dade
Developer
Posts: 4695
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: MacOS High Sierra BVHKernel CUDA program compilation error

Post by Dade » Wed Sep 09, 2020 10:54 am

Dieneel wrote:
Wed Sep 09, 2020 3:55 am
[LuxRays][16.914] [BVHKernel] Compiling kernels
[LuxRays][16.915] [BVHKernel] CUDA program compilation error:
nvrtc: error: failed to open libnvrtc-builtins.dylib.
Make sure that libnvrtc-builtins.dylib is installed correctly.
The problem is here: the NVRTC DLL is not found. NVRTC is the run time CUDA compiler and it is not included in NVIDIA driver (so we have to ship it with BlendLuxCore).

I don't how MacOS work but you should check if you are missing the "libnvrtc-builtins.dylib" file.
Support LuxCoreRender project with salts and bounties

Dieneel
Posts: 2
Joined: Wed Sep 09, 2020 3:31 am

Re: MacOS High Sierra BVHKernel CUDA program compilation error

Post by Dieneel » Wed Sep 09, 2020 5:08 pm

Hi Dade, thanks for your reply.

Yeah, I already check that. There is a file named libnvrtc-builtins.dylib with a shortcut symbol on it and libnvrtc-builtins10.1.dylib/libnvrtc-builtins10.2.dylib that come with the CUDA SDK.
I put all these files in the luxcore Bin directory, but it still says BVHKernel CUDA program compilation error.

Cycles and Octane for blender work fines with CUDA here.
iShot2020-09-10 01.04.26.png
I fond asimlar post realted with CUDA; https://github.com/yusuketomoto/chainer ... issues/107. Maybe this is just a path thing.
Not a programmer myself so yeah :lol:

Post Reply