PyLuxCore Tool Error ( v2.4, all scenes)

Use this forum for general user support and related questions.
User avatar
Dade
Developer
Posts: 4687
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by Dade » Fri Sep 11, 2020 7:33 am

acasta69 wrote:
Fri Sep 11, 2020 7:23 am
One more piece of info, hoping it helps finding a workaround.
The Interface-->Translation preference was slightly different in Blender 2.82: it was disabled by default (and was disabled in my previous test).
Enabling it as in the attached picture produces the same exact behaviour as the more recent Blender versions, no matter if language is set to "Automatic" or "English".
In the latest versions this setting is gone, translation is always enabled.
If I set the Translation language to English in v2.83, I'm able to replicate the problem on Linux too:

Code: Select all

scene.objects.1405993531811920.id = 1,326,487,202
Sincerely, this is a Blender bug that can potentially brake a lot of stuff but now that I'm able to replicate it, I can look for a work around.
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 4687
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by Dade » Fri Sep 11, 2020 7:45 am

Dade wrote:
Fri Sep 11, 2020 7:33 am
If I set the Translation language to English in v2.83, I'm able to replicate the problem on Linux too:
This is is really weird. I get the bug only during the session were I change the Translation language preference: if I close Blender and re-open, it works fine. To trigger the problem I have to change the preference...
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 4687
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by Dade » Fri Sep 11, 2020 10:41 am

I may have fixed the problem.
Support LuxCoreRender project with salts and bounties

acasta69
Developer
Posts: 352
Joined: Tue Jan 09, 2018 3:45 pm

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by acasta69 » Fri Sep 11, 2020 12:44 pm

The export looks correct now. Thank you!
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v445.87

gecko
Posts: 31
Joined: Mon Jan 01, 2018 11:10 pm

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by gecko » Sun Sep 13, 2020 8:35 pm

Dade wrote:
Fri Sep 11, 2020 10:41 am
I may have fixed the problem.
I can confirm that the latest 2.5 build exports correctly (both for the default scene as well as my large / complex one). Thanks Dade, this saves me a whole lot of trouble trying to patch up the export files!

Post Reply