LuxCoreUI config error

Use this forum for general user support and related questions.
Post Reply
chafouin
Posts: 108
Joined: Wed Jan 24, 2018 9:35 pm
Location: Los Angeles

LuxCoreUI config error

Post by chafouin » Wed Jul 29, 2020 5:02 am

I wanted to try the new chromatic aberration in LuxCoreUI as it's not in BlendLuxCore yet, and I'm getting this error when trying to load the LuxCore scene I saved from Blender:

RenderConfig loading error:
bad lexical cast: source type value could not be interpreted as target
Attachments
00001.zip
(198.97 KiB) Downloaded 6 times

User avatar
B.Y.O.B.
Developer
Posts: 3681
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreUI config error

Post by B.Y.O.B. » Wed Jul 29, 2020 8:56 am

This usually means some locale mismatch, using commas in one program and dots in another as decimal points.

By the way, non-uniform chromatic aberration is now supported in the addon.

CodeHD
Posts: 317
Joined: Tue Dec 11, 2018 12:38 pm
Location: Germany

Re: LuxCoreUI config error

Post by CodeHD » Fri Aug 07, 2020 11:25 am

I've just encountered the same issue.

It looks to me as if the mateiral/volume ids in the scene files have comma separation at the 1000's locations, i.e., like "1,600,508" instead of "1600508".

If I compare to old scene files, I see the latter case.
Attachments
scene.scn
(10.98 KiB) Downloaded 3 times

User avatar
Dade
Developer
Posts: 4498
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreUI config error

Post by Dade » Fri Aug 07, 2020 3:41 pm

It is this problem: https://github.com/LuxCoreRender/LuxCore/issues/390

Try to change this setting: https://github.com/LuxCoreRender/LuxCor ... -639427290

Blender apparently breaks C locale settings when you set English (i.e it starts to print numbers with "," separator for thousands).
Support LuxCoreRender project with salts and bounties

CodeHD
Posts: 317
Joined: Tue Dec 11, 2018 12:38 pm
Location: Germany

Re: LuxCoreUI config error

Post by CodeHD » Fri Aug 07, 2020 6:30 pm

Indeed, that setting affects it.

Unfortunately, it just changes the separator to a dot instead of comma :/

Post Reply