LuxCore didt see OpenCL devices on Linux

Use this forum for general user support and related questions.
mib2berlin
Posts: 13
Joined: Fri Apr 06, 2018 6:29 pm

Re: LuxCore didt see OpenCL devices on Linux

Post by mib2berlin » Wed Apr 18, 2018 10:52 am

Hm, 760 is shown, HD 4400 only in Luxmark not in the addon. If Luxmark render on the HD 4400 Luxcore should work too, doesn't it?

Thanks for watching, mib

User avatar
Dade
Developer
Developer
Posts: 2820
Joined: Mon Dec 04, 2017 8:36 pm

Re: LuxCore didt see OpenCL devices on Linux

Post by Dade » Wed Apr 18, 2018 10:54 am

mib2berlin wrote:
Wed Apr 18, 2018 10:52 am
Hm, 760 is shown, HD 4400 only in Luxmark not in the addon. If Luxmark render on the HD 4400 Luxcore should work too, doesn't it?
Yes, you should have command named "clinfo", can you post the output here ?
Support LuxCoreRender project with salts and bounties

mib2berlin
Posts: 13
Joined: Fri Apr 06, 2018 6:29 pm

Re: LuxCore didt see OpenCL devices on Linux

Post by mib2berlin » Wed Apr 18, 2018 1:53 pm

I don´t have clinfo but another tool check_opencl, output is:
If I try to compile clinfo it errors out CL.h is missing and I think this is a problem.

Code: Select all

Platform            : Intel(R) OpenCL
Platform extensions : cl_khr_icd cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_depth_images cl_khr_3d_image_writes cl_intel_exec_by_local_thread cl_khr_spir cl_khr_fp64 
Platform profile    : FULL_PROFILE
Platform vendor     : Intel(R) Corporation
Platform version    : OpenCL 1.2 LINUX
        Device number         : 0
        Device name           :        Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
        Device extensions     : cl_khr_icd cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_depth_images cl_khr_3d_image_writes cl_intel_exec_by_local_thread cl_khr_spir cl_khr_fp64 
        Device Opencl Version : OpenCL C 1.2 
        Device max comp unit  : 4


Test of directory creation :
Creation of /tmp/test_check_opencl directory is OK
 It will be removed
/tmp/test_check_opencl directory is removed

Test of directory creation with opencl name :
                Creation of "/tmp"/test_check_openc_cl/Intel(R) Corporation
                Creation of "/tmp/test_check_opencl/Intel(R) Corporation" : OK
                Creation of "/tmp/test_check_opencl/Intel(R) Corporation/Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz" : OK
                Creation of "/tmp/test_check_opencl/Intel(R) Corporation/Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz/4" : OK
I have installed:
intel-opencl-r5.0-63503.x86_64.rpm
intel-opencl-devel-r5.0-63503.x86_64.rpm
intel-opencl-r5.0-cpu-63503.x86_64.rpm

It seams it is only CPU installed, where I get GPU driver?

User avatar
Dade
Developer
Developer
Posts: 2820
Joined: Mon Dec 04, 2017 8:36 pm

Re: LuxCore didt see OpenCL devices on Linux

Post by Dade » Wed Apr 18, 2018 2:33 pm

mib2berlin wrote:
Wed Apr 18, 2018 1:53 pm
It seams it is only CPU installed, where I get GPU driver?
Ok, this make sense, I think BlendLuxCore shows only GPUs device (because they are now the only type of useful devices thanks to hybrid rendering) while LuxMark show every type of device.

I'm not sure but some time ago, Intel OpenCL for HD4000 was available only under Windows :?:
Support LuxCoreRender project with salts and bounties

mib2berlin
Posts: 13
Joined: Fri Apr 06, 2018 6:29 pm

Re: LuxCore didt see OpenCL devices on Linux

Post by mib2berlin » Wed Apr 18, 2018 2:42 pm

IIRC the test I made was on WIndows, haha.
It is not important to me, thank you for the help.
May in the future they support iGPU too.

Cheers, mib

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2809
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCore didt see OpenCL devices on Linux

Post by B.Y.O.B. » Wed Apr 18, 2018 2:55 pm

Yes, CPU devices are not shown in the addon.
https://github.com/LuxCoreRender/BlendL ... ig.py#L178
Support LuxCoreRender project with salts and bounties

Floke
Posts: 34
Joined: Mon Apr 09, 2018 1:20 pm

Re: LuxCore didt see OpenCL devices on Linux

Post by Floke » Sun Apr 07, 2019 7:38 pm

Guys I finally found solution for fedora systems and Nvidia cards! For OpenCL luxcore just needed to remove some files from "etc/OpenCL/vendors" directory. Only nvidia.icd must stay here and luxcore OpenCl start working!
Удачи всем!

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2809
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCore didt see OpenCL devices on Linux

Post by B.Y.O.B. » Sun Apr 07, 2019 8:29 pm

Great to hear that, thanks for posting the solution :)
Support LuxCoreRender project with salts and bounties

Floke
Posts: 34
Joined: Mon Apr 09, 2018 1:20 pm

Re: LuxCore didt see OpenCL devices on Linux

Post by Floke » Sun Apr 07, 2019 8:34 pm

Thanks for awesome render engine! =)

Post Reply