Viewport render crash on GPU Cuda

Use this forum for general user support and related questions.
User avatar
Dade
Developer
Posts: 4697
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Sat Sep 05, 2020 2:11 pm

But does the PC totally freeze/crash or just never get out of the compiling stage ? Is it only Blender to not respond or all the OS ?
Support LuxCoreRender project with salts and bounties

TStrolia
Posts: 38
Joined: Mon Jun 22, 2020 10:29 am

Re: Viewport render crash on GPU Cuda

Post by TStrolia » Sat Sep 05, 2020 2:27 pm

Dade wrote:
Sat Sep 05, 2020 2:11 pm
But does the PC totally freeze/crash or just never get out of the compiling stage ? Is it only Blender to not respond or all the OS ?
I think it's isolated to blender. The computer does just fine and I have not had windows freeze on me. The processes overview will show blenders CPU usage and power usage sky rocket but then after a few seconds the memory and CPU usage drop but the power usage stays at very high and my fans keep going like its still doing something but I really have no clue what because blender just hangs and if you even minimize blender it goes to not responding. It will just be like that seemingly indefinitely after starting the render or render preview. I but CPU rendering doesn't seem to have the problem.

As far as I can tell after testing all night it is isolated to GPU and doesn't matter how many/which graphics card I am using. Just the fact that I am using GPU rendering it just gets stuck. I don't have the problem in the material preview on the side though so I am guessing that is using CPU to render, because if it is able to take advantage of the GPU then it is strange that the material preview is working but nothing else.

Ok... Now I am confused... Now the normal render is working again but live view is hanging on compiling cuda kerenels..... Live preview shows 3D activity on the graphics card but no cuda usage and the memory seems to have filled but blender gets stuck and is not responding. It is sorta like my computer knows its working but blender doesn't...

User avatar
Dade
Developer
Posts: 4697
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Sat Sep 05, 2020 3:00 pm

Does LuxMark work ? An automatic Windows update may have broken you driver installation.
Support LuxCoreRender project with salts and bounties

TStrolia
Posts: 38
Joined: Mon Jun 22, 2020 10:29 am

Re: Viewport render crash on GPU Cuda

Post by TStrolia » Sat Sep 05, 2020 3:03 pm

Dade wrote:
Sat Sep 05, 2020 3:00 pm
Does LuxMark work ? An automatic Windows update may have broken you driver installation.
Checking luxmark now. Ill post back shortly

TStrolia
Posts: 38
Joined: Mon Jun 22, 2020 10:29 am

Re: Viewport render crash on GPU Cuda

Post by TStrolia » Sat Sep 05, 2020 3:05 pm

Dade wrote:
Sat Sep 05, 2020 3:00 pm
Does LuxMark work ? An automatic Windows update may have broken you driver installation.
Luxmark seems to be working fine. And I thought it might be drivers too. I ran a driver cleaner, updated windows and reinstalled the drivers. No luck. Doesn't mean that's not the problem but that usually fixes most driver problems so IDK

TStrolia
Posts: 38
Joined: Mon Jun 22, 2020 10:29 am

Re: Viewport render crash on GPU Cuda

Post by TStrolia » Sat Sep 05, 2020 3:06 pm

TStrolia wrote:
Sat Sep 05, 2020 3:05 pm
Dade wrote:
Sat Sep 05, 2020 3:00 pm
Does LuxMark work ? An automatic Windows update may have broken you driver installation.
Luxmark seems to be working fine. And I thought it might be drivers too. I ran a driver cleaner, updated windows and reinstalled the drivers. No luck. Doesn't mean that's not the problem but that usually fixes most driver problems so IDK
Scored 2692 on the test

User avatar
Dade
Developer
Posts: 4697
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Sat Sep 05, 2020 3:13 pm

Try to clear your kernel cache (and compile for about 5mins), it should be a directory like: C:\Users<user name>\AppData\Local\Temp\luxcorerender.org
Support LuxCoreRender project with salts and bounties

TStrolia
Posts: 38
Joined: Mon Jun 22, 2020 10:29 am

Re: Viewport render crash on GPU Cuda

Post by TStrolia » Sat Sep 05, 2020 3:18 pm

Dade wrote:
Sat Sep 05, 2020 3:13 pm
Try to clear your kernel cache (and compile for about 5mins), it should be a directory like: C:\Users<user name>\AppData\Local\Temp\luxcorerender.org
Just cleared the cache. I will run the ccompiler while I walk the dog and check back soon.

TStrolia
Posts: 38
Joined: Mon Jun 22, 2020 10:29 am

Re: Viewport render crash on GPU Cuda

Post by TStrolia » Sat Sep 05, 2020 3:31 pm

Dade wrote:
Sat Sep 05, 2020 3:13 pm
Try to clear your kernel cache (and compile for about 5mins), it should be a directory like: C:\Users<user name>\AppData\Local\Temp\luxcorerender.org
That seems to have done the trick. All seems to be right again in the world. I am going to try toggling back to OCL from Cuda and see if the issue still appears to be fixed

TStrolia
Posts: 38
Joined: Mon Jun 22, 2020 10:29 am

Re: Viewport render crash on GPU Cuda

Post by TStrolia » Sat Sep 05, 2020 3:48 pm

TStrolia wrote:
Sat Sep 05, 2020 3:31 pm
Dade wrote:
Sat Sep 05, 2020 3:13 pm
Try to clear your kernel cache (and compile for about 5mins), it should be a directory like: C:\Users<user name>\AppData\Local\Temp\luxcorerender.org
That seems to have done the trick. All seems to be right again in the world. I am going to try toggling back to OCL from Cuda and see if the issue still appears to be fixed
OCL fixed as well. Thank you so much Dade! I really appreciate it!

Post Reply