Opencl clenqueuwritebuffer bug

Use this forum for general user support and related questions.
Post Reply
User avatar
Sharlybg
Donor
Posts: 2011
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Opencl clenqueuwritebuffer bug

Post by Sharlybg » Fri May 08, 2020 12:31 pm

just a couple of time now that i get a bug while animating with 2.4 Cuda build. Each 48 frames i get an error "clenqueuwritebuffer". And render stop.
look like the gpu go out of memory. but this is no matter the scene size. as it happen now with a small size scene.

will try to reproduce it with a simpler scene for debugging.
Capture d'écran 2020-05-08 12.25.05.png
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Dade
Developer
Posts: 4255
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Opencl clenqueuwritebuffer bug

Post by Dade » Fri May 08, 2020 1:35 pm

It is likely to be some kind of memory leak with CUDA (it would be useful to understand if it happens only with CUDA or also with OpenCL).
Support LuxCoreRender project with salts and bounties

User avatar
Theo_Gottwald
Posts: 15
Joined: Fri Apr 24, 2020 12:01 pm

Re: Opencl clenqueuwritebuffer bug

Post by Theo_Gottwald » Wed May 13, 2020 9:58 pm

I also get this error, but when this happens, the computer needs a reboot.
After a reboot here it works - if the GPU Memory is large enough.
Here its like that, that even a restart of Blender will not fix the problem.
Only a restart of the computer will fix the problem.

User avatar
Dade
Developer
Posts: 4255
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Opencl clenqueuwritebuffer bug

Post by Dade » Wed May 13, 2020 10:18 pm

Theo_Gottwald wrote:
Wed May 13, 2020 9:58 pm
I also get this error, but when this happens, the computer needs a reboot.
After a reboot here it works - if the GPU Memory is large enough.
Here its like that, that even a restart of Blender will not fix the problem.
Only a restart of the computer will fix the problem.
This really sounds more like a driver bug than an application bug.
Support LuxCoreRender project with salts and bounties

User avatar
Theo_Gottwald
Posts: 15
Joined: Fri Apr 24, 2020 12:01 pm

Re: Opencl clenqueuwritebuffer bug

Post by Theo_Gottwald » Sun May 31, 2020 5:35 am

I can agree to that, because also Cycles sometimes just quits rendering.
I have 2x GTX 1080 currently. But seeing the rendertime I am working on something with RTX :-)
Just nor sure if i should take it for that price :-)
https://www.alibaba.com/product-detail/ ... 723bQTMzZ8
To night i had an animation rendering. Just at frame 37 it stopped rendering with this error.
If you want to try, download it here:


This one:
42 MB Scene.
This one is also for download.
42 MB Scene.

User avatar
Sharlybg
Donor
Posts: 2011
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Opencl clenqueuwritebuffer bug

Post by Sharlybg » Mon Jun 01, 2020 8:48 pm

I still have this error plus blender crash from time to time each 48 frames render.

Btw 150§ for a RTX 2080 TI is pretty strange. would like to see how this end up :roll:
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

Post Reply