The flickerfree animation challenge

Use this forum for general user support and related questions.
mischterlampe
Posts: 27
Joined: Fri Apr 03, 2020 6:22 pm

Re: The flickerfree animation challenge

Post by mischterlampe » Thu May 07, 2020 6:49 am

Dade wrote:
Wed May 06, 2020 10:26 pm
So is it light tracing ?
Yes, only if I disable light tracing, I get a flickerfree result.
If I use Bidir, it is also flickerfree, too.
What can I do now?

Fox wrote:
Wed May 06, 2020 11:53 pm
What if all the meshes are shaded as flat, will the pure 100% light tracing with envc flicker?
-------
EDIT
The blend file looks broken.
When i append objects to new blend file, the light tracing looks better.
Shaded all as flat with pure 100% light tracing and envc persistent flickers, too.

I appended the whole collection to a new blender. Used the same hdri and added a sun, but same result.

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: The flickerfree animation challenge

Post by epilectrolytics » Thu May 07, 2020 7:21 am

I've not looked into your file yet but this problem appears in all my animation attempts too.
example
Light tracing is not consistent in animation, the caustic brightness is always varying to different degrees depending on the scene.
It may be caused by the metropolis algorithm finding paths with different efficiency in every other frame or a floating point precision problem when the caustics cover a small area compared to the scene bounding box (issue#312).
Sun and sky is always more problematic than lamp lights and HDRIs are worst in this respect.

BiDir doesn't show this problem but without BiDirVM SDS-caustics are missing and it's slow on CPU.
You might try caustic cache instead of light tracing.
It's slower but sometimes it works, at least without flicker from frame to frame though I have noticed that cached caustics tend to get darker with more samples.

User avatar
Dade
Developer
Posts: 4252
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: The flickerfree animation challenge

Post by Dade » Thu May 07, 2020 10:33 am

I'm able to reproduce the problem here, the frame 54 (and 58) is fine (caustics only rendering):

lighttracing.pgi-ind.env.0054.png

while there is a jump in brightness in frame 56:

lighttracing.pgi-ind.env.0056.png

I'm checking what is going on.
Support LuxCoreRender project with salts and bounties

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: The flickerfree animation challenge

Post by epilectrolytics » Thu May 07, 2020 10:39 am

epilectrolytics wrote:
Thu May 07, 2020 7:21 am
You might try caustic cache instead of light tracing.
Just tried, doesn't work :(
I guess the many glossy materials in the scene make the problem somewhat worse.

mischterlampe
Posts: 27
Joined: Fri Apr 03, 2020 6:22 pm

Re: The flickerfree animation challenge

Post by mischterlampe » Thu May 07, 2020 10:54 am

Your example looks very similar.
Thank you for the explanation. But what is the solution to this? No light tracing for animation in this case?

When I use caustic cache instead and make it persistent, I get flickering, too.
But when I don't use the persistent mode, I get a flickerfree version.
https://streamable.com/ygoi9r
But you can see the cache in the image, mainly on the black bowl. So I decreased the lookup radius of the caustic cache and made it 10 times smaller and the result I get with a value of 0.0005 m is good.
causticcache.notracing.nonpers.0046.0.0005.png
It takes forever, almost 10times. And this is just a 1/3 of the resultion. So at the end 1 frame will take 10min*3*3=180min. Uhh.

Do you have any caustic setting tips?

Nonetheless, the caustics of the glass bottle are very weak
causticcache.notracing.nonpers.caustic crop.png

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: The flickerfree animation challenge

Post by epilectrolytics » Thu May 07, 2020 11:29 am

mischterlampe wrote:
Thu May 07, 2020 10:54 am
But what is the solution to this? No light tracing for animation in this case?

Do you have any caustic setting tips?
Sadly I don't have any solution for this except waiting until the developer finds a fix.
It's a problem I struggle with since light tracing was introduced.
Since fixing issue #312 things have gotten more stable but not entirely.
In some scenes (see my example above) there are only a couple of frames overblown, then I render those again manually.

Settings depend on each scene, in my experience glossy materials worsen the problem but again in this scene they cannot be disabled without destroying the danish mood.

I'd go for rendering the thing with light tracing and indirect PGI only (fastest method) and rerender the failed frames.

User avatar
Dade
Developer
Posts: 4252
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: The flickerfree animation challenge

Post by Dade » Thu May 07, 2020 12:15 pm

I may have fixed the problem (Metropolis initial bias is a very delicate matter). The animation is rendering fine here. Can you try (when is ready in ~3 hours) a new automatic build ?
Support LuxCoreRender project with salts and bounties

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Build 20200507.3

Post by epilectrolytics » Thu May 07, 2020 5:06 pm

Somehow light tracing with sun & sky is now broken.
Refractive caustics are way slower than before and in hybrid mode illumination from the sky is missing :?
Screenshot3.jpg
See test file with or without light tracing activated.
test.blend.zip
(496.2 KiB) Downloaded 8 times

mischterlampe
Posts: 27
Joined: Fri Apr 03, 2020 6:22 pm

Re: The flickerfree animation challenge

Post by mischterlampe » Thu May 07, 2020 6:11 pm

The flickering is way better, but there is still an increase of brightness. It feels more linear.
https://streamable.com/411d7q

But what I miss are the refractive caustics. Light tracing and PhotonGI ind. cache is on and persistent.
Here is the old flickering version:
flickeringversion.png
and here the new version:
6b31725_nonflickering_version_nocaustics_.png

User avatar
Dade
Developer
Posts: 4252
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: The flickerfree animation challenge

Post by Dade » Fri May 08, 2020 10:03 am

mischterlampe wrote:
Thu May 07, 2020 6:11 pm
But what I miss are the refractive caustics. Light tracing and PhotonGI ind. cache is on and persistent.
I should I have fixed this problem too:

caustics.jpg

About the flickering, there are 2 problems:

1) the halt condition is currently based on the sum of eye (GPU) and light (CPU) samples. Clearly if your GPU(s) is fast enough (and/or the CPU is slow enough), you can end rendering only (or nearly only) eye samples in a short rendering.

2) Metropolis has a warm up period and is unbiased on the long run. This mean that an early stage of the rendering can look quite different from a long run. This is an early stage:

caustics-1.jpg

and this is the long run of exactly the same rendering:

caustics-2.jpg

The perceived brightness of the 2 images is clearly different but there is nothing wrong, it is just a large initial error (aka noise) that is reduced on the long run.
Clearly, problem #1 can exacerbate the #2.

So, my theory is that flickering, with the very latest version should disappear more samples you render (i.e. if try to render the animation with a lot more time per frame, it should disappear).

I have some idea to alleviate the problem but the end result is still you need to render more time per frame (they takes about 20secs on my PC).
Support LuxCoreRender project with salts and bounties

Post Reply