The flickerfree animation challenge

Use this forum for general user support and related questions.
mischterlampe
Posts: 27
Joined: Fri Apr 03, 2020 6:22 pm

The flickerfree animation challenge

Post by mischterlampe » Wed May 06, 2020 6:24 pm

Hi there

I have a probleme and tried to find a solution for almost 40h.
I haven't found one yet, so I thought I make a challenge out of it.
The first one who publishes a solution will get 50€. This is a "private" problem, so it has nothing to do with a commercial project, it is just that I'm eager and I want a solution.
I love the results of luxcore and I want to use it for animation, too.

I would like to render a fly-through animation in the sample scene "danish mood".
I just added a sun for nice reflections.
The first time I rendered it, I got flickering lights reflected from the sideboard and in the caustics of the glass bottle.
I thought I activated the radioactive rendering mode by mistake.
Here is the video:
https://streamable.com/8t275w

and my test file:
https://easyupload.io/hwuf1c

The flickering is most visible on the wall in the beginning and in the dark bowl at the end of the video.
I tried almost everything. I want to render the animation with gpu for faster results.
I want to use "add light tracing" for better looking results.
And I would like to use the phtongi indirect and env cache, too. This looks the best to me.
But getting a flickerfree animation is the goal.

I'm working in blender 2.83.13 and luxcore 2.4 from 4th of may ( I have also tried different versions)

Here is what I've tried.

I used
- every cache (photon gi only /photongi indirect / photongi caustic) and env cache, alone and in different combinations
- both caches also as saved ones (persistent caches)
- blurring the caches with motion blur of the camera with the frame number of the animation, saved the caches and used them with a non motionblured camera
- clamping to 5 and to the suggested value of 0.62 and even 100000.
- different resolutions of the hdris
- denoising and no denoising
- set the glossiness threshold of the lighttracing to 1
- the "god mode" by just typing "god" when your are in blender ( just kidding)
but maybe I made a mistake somewhere.

I found only 2 solutions, which didn't flicker, but these are not so "good" looking:
1. using bidir rendering: very slow (only cpu), very weak caustics (on the wall/in the shadow of the glass bottle)
2. disabling "add light tracing": no good looking results, no light reflection on the wall, no caustics in the shadow of the glass bottle.

After all the testing (at least 40h), I think, there is no way of getting a flickerfree result with bright light reflection on glossy surfaces and refractive caustics.
I wish i would get the result of a stills rendering with "add light tracing", photongi ind. cache and env. cache in an animation.

I'm desperated. I like luxcore, but this is a huge problem for me.
So I started this challenge.
I'm looking for the right render settings. Other methods are welcome and as long as the effort is small to get the right result, they are ok.
But my main goal is to get the right render settings.
Otherwise an explanation, why it won't work would be sobering but helpful. In this case I'll donor the money to the luxcore devs.

I'm really hoping someone can help me.

Best Philip

User avatar
Dade
Developer
Posts: 4240
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: The flickerfree animation challenge

Post by Dade » Wed May 06, 2020 6:39 pm

It may be related to a bug recently fixed: https://github.com/LuxCoreRender/LuxCore/issues/329

If you use only PhotonGI indirect + persistent cache + light tracing, it should work, if it doesn't, it is a bug.
Support LuxCoreRender project with salts and bounties

mischterlampe
Posts: 27
Joined: Fri Apr 03, 2020 6:22 pm

Re: The flickerfree animation challenge

Post by mischterlampe » Wed May 06, 2020 7:38 pm

Hi Dade,

I think it is a bug. Here is the result with your settings.
https://streamable.com/pigra2
I used light tracing photongi+ind. I'm using the 2.4 cuda from yesterday.
Do you need the blend file? What can I do?

User avatar
Sharlybg
Donor
Posts: 2008
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: The flickerfree animation challenge

Post by Sharlybg » Wed May 06, 2020 7:41 pm

mischterlampe wrote:
Wed May 06, 2020 7:38 pm
Hi Dade,

I think it is a bug. Here is the result with your settings.
https://streamable.com/pigra2
I used light tracing photongi+ind. I'm using the 2.4 cuda from yesterday.
Do you need the blend file? What can I do?
Is persistent cache is enable ?
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

mischterlampe
Posts: 27
Joined: Fri Apr 03, 2020 6:22 pm

Re: The flickerfree animation challenge

Post by mischterlampe » Wed May 06, 2020 7:53 pm

I think so. This is the first rendering:
[LuxCore][67.688] PhotonGI total memory usage: 3092Kbytes
[LuxCore][67.688] Saving persistent PhotonGI cache: D:\Downloads\DanishMood(1)\DanishMood\flickering post\dades3.pgi
[LuxCore][67.844] PhotonGI persistent cache saved: 1344 Kbytes

and this message comes with the second:
[LuxRays][144.734] [MBVHKernel] Program cached
[LuxCore][144.766] [PathOCLRenderEngine] OpenCL task count: 262144
[LuxCore][144.766] [PathOCLBaseRenderEngine] OpenCL max. page memory size: 18014398509481983Kbytes
[LuxCore][144.766] Loading persistent PhotonGI cache: D:\Downloads\DanishMood(1)\DanishMood\flickering post\dades3.pgi
[LuxCore][144.875] Compile Geometry

User avatar
Dade
Developer
Posts: 4240
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: The flickerfree animation challenge

Post by Dade » Wed May 06, 2020 7:56 pm

Try to isolate the problem: if you disable only PGI indirect, does it works ? If you disable only light tracing, does it work ?
Support LuxCoreRender project with salts and bounties

mischterlampe
Posts: 27
Joined: Fri Apr 03, 2020 6:22 pm

Re: The flickerfree animation challenge

Post by mischterlampe » Wed May 06, 2020 8:27 pm

Here is the result of a disabled photongi ind. cach. No other cache is used and light tracing is on.
https://streamable.com/wagmbo

here is the result for the disabled lighttracing. this doesn't flicker
https://streamable.com/jquwks

mischterlampe
Posts: 27
Joined: Fri Apr 03, 2020 6:22 pm

Re: The flickerfree animation challenge

Post by mischterlampe » Wed May 06, 2020 8:38 pm

When I disable the checkbox PhotonGICaches I get another kind of flickering
https://streamable.com/jswwmd

The funny thing is, if I only enable this checkbox and no other caches, it says "All caches disabled"
Does it make a difference if this checkbox is enabled and saying "all caches disabled" and disabling this checkbox?

User avatar
Dade
Developer
Posts: 4240
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: The flickerfree animation challenge

Post by Dade » Wed May 06, 2020 10:26 pm

So is it light tracing ?
Support LuxCoreRender project with salts and bounties

Fox
Posts: 421
Joined: Sat Mar 31, 2018 11:17 am

Re: The flickerfree animation challenge

Post by Fox » Wed May 06, 2020 11:53 pm

What if all the meshes are shaded as flat, will the pure 100% light tracing with envc flicker?
-------
EDIT
The blend file looks broken.
When i append objects to new blend file, the light tracing looks better.

Post Reply