Denoiser issues

Use this forum for general user support and related questions.
Post Reply
caretaker
Posts: 11
Joined: Fri Jan 03, 2020 11:53 am

Denoiser issues

Post by caretaker » Mon Jan 13, 2020 6:16 pm

rendering a scene with 1000 samples came out ok-ish, however denoiser went bad and flashed some artifacts
Image
Image

Any ideeas?
Attachments
test 1.jpg
test 2.jpg

User avatar
Dade
Developer
Posts: 3919
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Denoiser issues

Post by Dade » Tue Jan 14, 2020 9:36 am

I assume we are talking of Intel Oidn (you could try BCD denoiser too in your case). I assume you are also using normal glass (not architectural ?).

Oidn has some problem with the LuxCore glass because of the noise in the Albedo AOV. Reducing the amount of glass reflection can be a workaround to the problem but it will change how the scene look.

If you post a simplified the scene with just glass, background and some light source, I may be able to tell you more.
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3353
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Denoiser issues

Post by B.Y.O.B. » Tue Jan 14, 2020 9:48 am

It looks to me like OIDN might extrapolate some bright fireflies into those artifacts. Clamping could help to counter this, or you could try to find which material/light source causes the fireflies and disable this influence, e.g. by turning off visibility in indirect specular rays.

User avatar
lacilaci
Donor
Posts: 1846
Joined: Fri May 04, 2018 5:16 am

Re: Denoiser issues

Post by lacilaci » Tue Jan 14, 2020 10:11 am

As B.Y.O.B. said. Clamping should solve the issue, It happened to me few times when rendering unclamped with strong lightsources.

caretaker
Posts: 11
Joined: Fri Jan 03, 2020 11:53 am

Re: Denoiser issues

Post by caretaker » Thu Jan 16, 2020 9:12 am

That fixed the issue clamping with the recommended value by luxcore
Final results are here

viewtopic.php?f=3&t=1713

Post Reply