Access violation

Use this forum for general user support and related questions.
Post Reply
User avatar
lacilaci
Donor
Posts: 1934
Joined: Fri May 04, 2018 5:16 am

Access violation

Post by lacilaci » Mon Jan 13, 2020 11:15 am

when using emission node and at the same time pgi first it will work, but changing emission node from auto DLS to enabled or disabled will trigger blender crash.

from console:
em_pgi.jpg

User avatar
B.Y.O.B.
Developer
Posts: 3760
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Access violation

Post by B.Y.O.B. » Mon Jan 13, 2020 11:58 am

I can not reproduce this on Windows 10 with neither Path CPU nor Path OCL engines.

Can you provide a testscene?

User avatar
lacilaci
Donor
Posts: 1934
Joined: Fri May 04, 2018 5:16 am

Re: Access violation

Post by lacilaci » Mon Jan 13, 2020 12:29 pm

B.Y.O.B. wrote:
Mon Jan 13, 2020 11:58 am
I can not reproduce this on Windows 10 with neither Path CPU nor Path OCL engines.

Can you provide a testscene?
well... can't replicate it in new scene and when I strip down main scene where it happens then it works... So far I only know that it's triggered when enabling emission on material with pgi on... shit.

User avatar
Dade
Developer
Posts: 4677
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Access violation

Post by Dade » Mon Jan 13, 2020 12:54 pm

Is it the only light emitter in the scene ?
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 4677
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Access violation

Post by Dade » Mon Jan 13, 2020 12:58 pm

To further elaborate: PhotonGI does light tracing so there is no direct light sampling at all and DLS flag should have no direct impact at all on the PhotonGI pre-processing step. So the problem is a bit strange.
Support LuxCoreRender project with salts and bounties

User avatar
lacilaci
Donor
Posts: 1934
Joined: Fri May 04, 2018 5:16 am

Re: Access violation

Post by lacilaci » Mon Jan 13, 2020 1:05 pm

Dade wrote:
Mon Jan 13, 2020 12:58 pm
To further elaborate: PhotonGI does light tracing so there is no direct light sampling at all and DLS flag should have no direct impact at all on the PhotonGI pre-processing step. So the problem is a bit strange.
there is bunch of lightsources. I don't need the emitter so I can work around it, but wanted few objects to look as if they're lightsources... it's all good unless I also enable photongi. So far I tried to see if the problem is instances, multimaterial, other materials or cache persistence file. Everything works in isolated scene...

I'm busy and I can work around the issue for now, maybe I'll get back to this later when I have more time or if it would happen in a simpler scene.

Post Reply