LuxCore Vector Displacements

Our forum gallery for displaying your finished renders.
User avatar
Dade
Developer
Posts: 3570
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCore Vector Displacements

Post by Dade » Tue Nov 05, 2019 1:59 pm

kumaran7 wrote:
Tue Nov 05, 2019 1:18 pm
Displacement test build link please.
It is included in automatic builds (however, this feature has not yet been exposed in BlendLuxCore so it can not yet be used with some hand editing of the scene): viewtopic.php?f=9&t=736
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3088
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCore Vector Displacements

Post by B.Y.O.B. » Thu Dec 05, 2019 12:30 pm

Hi,

I think it only makes sense to add this scene to the testscene repo once the BlendLuxCore displacement support is implemented.
In the meantime, I was wondering what the license of this scene is? I can only find the youtube description as source, but was that the first time it was uploaded, and under which licensing?

User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: LuxCore Vector Displacements

Post by u3dreal » Thu Dec 05, 2019 6:15 pm

I could have a look at this in BlendLuxCore or who is the maintainer ???

cheers u3dreal
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
B.Y.O.B.
Developer
Posts: 3088
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCore Vector Displacements

Post by B.Y.O.B. » Fri Dec 06, 2019 12:58 am

u3dreal wrote:
Thu Dec 05, 2019 6:15 pm
I could have a look at this in BlendLuxCore or who is the maintainer ???
Sure, contributions are welcome.
As a proof of concept I have started something here a while ago: https://github.com/LuxCoreRender/BlendL ... he.py#L157
It worked in final render, but I have not investigated yet how best to support viewport updates.

I am the main author of BlendLuxCore, if you have any questions, feel free to ask me.
To discuss this, it's probably best if you open an issue in the repo: https://github.com/LuxCoreRender/BlendL ... issues/new

User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: LuxCore Vector Displacements

Post by u3dreal » Sat Dec 07, 2019 1:18 pm

OK seems i'll have a look to see if i get the concept of the code. :D
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
B.Y.O.B.
Developer
Posts: 3088
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCore Vector Displacements

Post by B.Y.O.B. » Tue Dec 17, 2019 2:10 pm

I added the vector displacement node to the Blender addon, this scene can now be rendered with the attached setup.
However, there are some weird lines appearing along the model, for example on the right, not sure what that's about.
Attachments
untitled.jpg
Capture.PNG

neo2068
Developer
Posts: 139
Joined: Tue Dec 05, 2017 6:06 pm
Location: Germany

Re: LuxCore Vector Displacements

Post by neo2068 » Tue Dec 17, 2019 2:58 pm

B.Y.O.B. wrote:
Tue Dec 17, 2019 2:10 pm
I added the vector displacement node to the Blender addon, this scene can now be rendered with the attached setup.
However, there are some weird lines appearing along the model, for example on the right, not sure what that's about.
These lines are also visible in the cycles video @ 5:20 Min (https://youtu.be/iNAdi1nzOvE?t=317). It seems to be releated with the uv map.
i7 5820K, 32 GB RAM, NVIDIA Geforce GTX 1080 + GTX 780, Windows 10 64bit, Blender 2.81a
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3088
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCore Vector Displacements

Post by B.Y.O.B. » Tue Dec 17, 2019 3:09 pm

Maybe the subdiv shape in LuxCore is not handling the UVs properly?

User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: LuxCore Vector Displacements

Post by u3dreal » Tue Dec 17, 2019 3:31 pm

Nice !
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

provisory
Posts: 227
Joined: Wed Aug 01, 2018 4:26 pm

Re: LuxCore Vector Displacements

Post by provisory » Tue Dec 17, 2019 7:07 pm

In Blender 2.81 they improved Cycles behavior:
https://wiki.blender.org/wiki/Reference ... .81/Cycles
Adaptive Subdivision
Cycles adaptive subdivision now stitches faces to avoid cracks between edges, that may be caused by displacement or different materials.
Image

Post Reply