Laci's wip

Post your tests, experiments and unfinished renderings here.
User avatar
lacilaci
Posts: 461
Joined: Fri May 04, 2018 5:16 am

Re: Laci's wip

Post by lacilaci » Fri Nov 30, 2018 6:15 am

lacilaci wrote:
Fri Nov 30, 2018 5:51 am
lacilaci wrote:
Thu Nov 29, 2018 12:58 pm
Please tell me you can fix this...

Unfornately I cannot provide scene atm.
But problem should be present in all cases I guess..
Ok, so what I found out is that in my original scene where it is lit only by hdri the bump looks right on opencl.
But in my main scene where the boards are linked to, and which is lit by flat colo+sun(distant) + 2 hidden interior lights, opencl looks wrong!
OMG I'm so stupid, I had the object for floorboards two times in my scene, so what was happening:
On cpu the linked boards would show up(which i adjusted in it's own scene) on opencl I was seeing the boards that were originally appended. I swear I hate 2.79 and linking and managing groups.

It was also slowing down rendering considerably lol. Now I'm getting 2K render in few minutes

User avatar
lacilaci
Posts: 461
Joined: Fri May 04, 2018 5:16 am

Re: Laci's wip

Post by lacilaci » Fri Nov 30, 2018 10:30 am

Alright, so here's now a 20min. 4K rendering quick test. I'm ready to turn this place into an office now... slowly :D
Attachments
tone_test.jpg

User avatar
FarbigeWelt
Posts: 362
Joined: Sun Jul 01, 2018 12:07 pm
Location: Switzerland
Contact:

Re: Laci's wip

Post by FarbigeWelt » Fri Nov 30, 2018 12:40 pm

Not exactly „Army of me“ but Army of chairs.

I like, and more of it please.
Microsoft Windows 10 Professional, intel i7 4770K, 32 GB, AMD R9 290x 4 GB, AMD R9 390x 8 GB
Instagrammer, please join #luxcorerender for your renderings.

User avatar
lacilaci
Posts: 461
Joined: Fri May 04, 2018 5:16 am

Re: Laci's wip

Post by lacilaci » Fri Nov 30, 2018 12:47 pm

FarbigeWelt wrote:
Fri Nov 30, 2018 12:40 pm
Not exactly „Army of me“ but Army of chairs.

I like, and more of it please.
lol, thanks.
Although it's always chair in focus in these last few posts, I'm actually figuring out lighting for the scene. But it's easier for me to use a "real" object in the scene to judge the scene lighting.
I like to use this approach for my own works cause if I figure this first then it's just fun populating the space... more or less... But it still doesn't mean it won't change in the end.

User avatar
lacilaci
Posts: 461
Joined: Fri May 04, 2018 5:16 am

Re: Laci's wip

Post by lacilaci » Fri Nov 30, 2018 3:48 pm

5min. volume test.. This time no denoising, as I'd clearly need more samples for denoiser to work properly.
Attachments
volume.jpg

User avatar
lacilaci
Posts: 461
Joined: Fri May 04, 2018 5:16 am

Re: Laci's wip

Post by lacilaci » Fri Dec 07, 2018 11:08 am

a small update... too much work and no free time...
Attachments
01.jpg
02.jpg

User avatar
lacilaci
Posts: 461
Joined: Fri May 04, 2018 5:16 am

Re: Laci's wip

Post by lacilaci » Fri Dec 07, 2018 8:39 pm

Ok, so I found out that I get some strange behavior with different light strategies... It seems that only "power" is able to keep strong lights like sun and interior lights behave correctly. I do use heavy clamping which might influence the results. Every other mode except power gives me this weak blending mode between lightsources and it always stays that way during rendering... With power it however seems that all lights keep their respective contribution to scene even with very heavy clamping...
I will hopefuly be able to provide some renders etc. soon, but I'm super busy atm... It is super strange though how dramatically lighting strategy changes the overal lighting. I would say it only changes how lights are sampled but now it seems that everything other than "power" breaks lighting completely...

User avatar
lacilaci
Posts: 461
Joined: Fri May 04, 2018 5:16 am

Re: Laci's wip

Post by lacilaci » Fri Dec 07, 2018 8:56 pm

here a comparison between power and log-power where "power" gives proper balance(stronger sun) and logpower completely shifts exposure as if lightbulbs were stronger source, but in GI you can clearly tell they're not, this looks all kinds of wrong.

I understand that clamping can introduce bias but I thought that if I change light strategy, I can experience this or that light to give more or less noise, cause of how it's being sampled. However like I mentioned, this completely shifts balance and while gi from sun is still kinda strong, direct light looks weak.

EDIT: every mode including dlcs looks super wrong when strong light competes with weak ones. Only power works, and power mode is also the only one working very well with super heavy clamping.

EDIT2: I now also remember having some hard times in previous scenes when I wanted to use some clamping, never thought that light strategy could actually break that. This can't be normal. And if it is, maybe default to power instead of log-power cause it is super easy to break with clamping.
Attachments
logpower.jpg
power.jpg

User avatar
B.Y.O.B.
Developer
Posts: 1825
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Laci's wip

Post by B.Y.O.B. » Fri Dec 07, 2018 10:00 pm

Have you tried rendering the image until it was noise-free (without denoiser)?
In the logpower rendering, the sun seems to be undersampled.

Also note that the clamping adapts as more samples come in. The effect you see might come from the fact that one light strategy samples the sun more than the other ligth strategy, so the clamping adapts differently, depending on if more bright or more dark samples are coming in.
A clamping value that is too small can lead to all sorts of undesired effects and should be avoided.
Support LuxCoreRender project with salts and bounties

User avatar
lacilaci
Posts: 461
Joined: Fri May 04, 2018 5:16 am

Re: Laci's wip

Post by lacilaci » Fri Dec 07, 2018 10:10 pm

B.Y.O.B. wrote:
Fri Dec 07, 2018 10:00 pm
Have you tried rendering the image until it was noise-free (without denoiser)?
In the logpower rendering, the sun seems to be undersampled.

Also note that the clamping adapts as more samples come in.
So a clamping value that is too small can lead to all sorts of undesired effects and should be avoided.
Yes and I also tried rendering region to be sure. Logpower never gets the same values as power / strong lights stay very weak in direct contribution but they still do seem to contribute quite well in GI. I have unfinished portion of the scene that is hard to reach(Mostly lit indirectly) and it looks very wrong unless I use "power".
It seems that both uniform and logpower not only redistribute samples but completely shift exposure/balance. It is very similar with DLCS where direct light is stronger but still looked very odd..

I understand that heavy clamping leads to problems, but it doesn't too much with "power" it would seem. And also, in this case I'm not even using sun, rather than distant light and suggested clamp value is way bellow what I actually used.

I will try to create a simple scene illustrating the issue, sometimes during next week if I won't be able to do so sooner.. But I can't believe that a sampling weights could create such a different lighting.

Post Reply